Start a new topic

VC707 and FMC116 Cannot be configured by JTAG

[size=4]When we test the demo project from the Page 61 of "4FM_Get_Started_Guide", we cannot program the FPGA through iMPACT.[/size]

[size=4]The problem is if I just connect the FPGA to the laptop without plugging the FMC116 into FMC Port, I can program the FPGA quite well.[/size]
[size=4]But when I plug FMC116 into FPGA, the iMPACT shows that:[/size]
[size=4]PROGRESS_START - Starting Operation.[/size]
[size=4]INFO:iMPACT:583 - '1': The idcode read from the device does not match[/size]

[size=4]the idcode in the bsdl File.[/size]

[size=4]INFO:iMPACT:1578 - '1':  Device IDCODE :        00000000000000000000000000000000[/size]

[size=4]INFO:iMPACT:1579 - '1': Expected IDCODE:    00000011011010000111000010010011[/size]

[size=4]And also shows "Program failed"[/size]

[size=4]I think the problem should be referred to "The attached FMC card must implement a TDI-to-TDO connection via a device or bypass jumper to ensure [/size]

[size=4]that the JTAG chain connects to the FPGA U1." on the page 26 of "ug885_VC707_Eval_Bd".[/size]

[size=4]But I don't find the bypass jumper, could you tell me which connector or jumper is on FMC116?[/size]

[size=4]Or if this is not the solution of the problem, could you tell how can I fix that, please?[/size]


Dear Ethan,

Please do not double post on both private/public area. This does not speed up the process, I am locking this topic.

Best Regards,
This topic is being closed because the issue is considered as resolved by 4DSP. Feel free to create a new topic for any further inquiries.