Start a new topic

Low frequency ADC-DAC signals with fmc 150 module on ml605 board

Hi,
My embedded system application requires
1) ADC to allow frequency 0 Hz to ~ 250 kHz and 
2) DAC output within frequency range 0 Hz to ~25 kHz.
The FMC 150 module that I have right now is ac coupled and essentially both the ADC and DAC has high pass filtering effects. The analog input allowed is between 400 kHz - 500 MHz (ADC). The analog output lies between 3 MHz - 82 MHz as written in the manual. I bought this fmc 150 module together with the ml605 evaluation kit (virtex 6 fpga from xilinx). Is it possible to modify the fmc 150 module to allow low frequency components by modify the ac coupling module or something similar?


Any help will be really appreciated.
Sayan 


This topic is being closed because the issue is considered as resolved by 4DSP. Feel free to create a new topic for any further inquiries.
Okay then. Thanks for the suggestions.


Sayan
Dear Sayan,


No this is standard firmware design iterations; you have a working reference design and you are integrating it to match your need. Maybe try a FPGA engineering forum where they assert constraining a firmware and such things.


Best Regards,

Arnaud
Hi,
Can you provide me some reference or guideline about how to specify the constraints or modify the designs including the microblaze system so that the signals are routed properly?
Any help will be appreciated.


Sayan
Dear Sayan,


I would believe that because the microblaze resources are placed in the FPGA it causes the design to be harder to route for the Xilinx tools and maybe you would need to add extra constraints or such things. This is something common in a firmware design when integrating a solution.


Best Regards,
Arnaud
Hi,
I am having one more problem. I was using the fmc 150 module with ml605 board with the reference design given from Avnet. I connected the DAC outputs directly to the ADC inputs for checking. I observed that when I include a microblaze processor based embedded system, the DAC outputs are getting severely distorted and not following the input properly. However, when I download the same design removing the embedded system component, the DAC outputs become normal again. There is no common signal between the fmc 150 ADC-DAC module and the microblaze processor based embedded component. The only common component is that I used a 200 Mhz clock derived using a mmcm block (the same mmcm block outputs also drive part of the fmc 150 adc-dac system) to drive the microblaze system.
Any idea on why this is happening? Is there any commonly known remedy?


Sayan
Dear Sayan,


Unfortunately, there is nothing I am aware of. I believe the only solution here is to purchase a FMC151 which is the DC coupled version based on FMC150.


Best Regards,
Arnaud