Start a new topic

No Ethernet link for FMC126 on VC707

Hi 4DSP,

I installed all of your stuff and is struggling to make the FMCxxxApp program work.  As listed on the FAQ, many things can go wrong on the Ethernet as such; but my problem is that whenever I program the board with the .bit file supplied, I do not get any link.

The application reports the interfaces correctly and I can get link with some of the BIST etc. Xilinx images.  I tried on two different computers, and I also tried to resynthesise your reference design from within you GUI application; but the new .bit file behaves the same.

What can possibly be the problem - I guess I should get a link even if there was no FMC board present?

Best regards,

Hello Torben,
I am not sure what you mean by "I do not get a link", on my side, tried the firmware (244_vc707_fmc126.bit, modified 10/10/2012). This is the firmware many customers are using just fine. Let me detail what I have done and what I could see:
1) The board is powered up, some of the LEDs on VC707 - Ethernet are lit.
2) Programming the board with JTAG, at this time the fan on VC707 goes down, then restarts. At the exact same moment, the PHY LEDs goes off and are lit again after about one second.
3) The software is ran, on my side did not attach FMC126 as I don't have any, used the following application arguments: FMC12xapp 1 VC707 1 0 0
4) On the output I see:
Number of devices found : 3
  0. \DEVICE\{D34BC2E6-80CD-4C72-9CAB-326225B1BAEA}
    - Broadcom 4313 802.11b/g/n
  1. \DEVICE\{7120AB20-B4F4-4749-A995-3C8FB7B45B57}
    - Intel(R) 82577LC Gigabit Network Connection
  2. \DEVICE\{48D2E642-621A-4481-B0C5-E43185B05556}
    - Microsoft Virtual WiFi Miniport Adapter
Start of program
Constellation ID : 244
Number of Stars  : 5
Software Build  : 0x5074C736
Firmware Build  : 0x00000000
Firmware Version : 0.1
Found FMC126-VC707 hardware (Ethernet Firmware)
Could not detect FMC12x hardware, exiting
The only thing I can come up with is the link speed, it should be on a 1000 (gigabit) ethernet adapter, I believe there are some issues on 10/100 adapters.
Note that my "Local Area Connection" states "Unidentified network".
Maybe show me some codes or errors, I cannot do anything more with the information you provided.
Best Regards,

Hi Arnaud,

Sorry - what I meant by no link was:  The link LED is off at my interface, and displayed as "unconnected" inside Windows.

The output I get:

> .\Fmc12xApp.exe 1 VC707 1 0 0
Number of devices found : 2
  0. \DEVICE\{73D76413-7985-4F4F-9BB2-03E587D1741A}
    - Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
  1. \DEVICE\{DF5710FB-34C4-4323-B3D9-276139CADBD7}
    - ASIX AX88772 USB2.0 to Fast Ethernet Adapter
Start of program
Could not obtain sipcid table (error ffffffff), exiting

(I also tried on another computer when I realised GbE might be a requirement - same result)

I tried to disconnect the FMC board as well.  A few more observations:
[li]The GPIO LED 0 is on (2 and 3 if you press the SW reset SW8)[/li]
[li]The Duplex and 1000x Ethernet LED are on; but no traces of activity[/li]
[/list]As mentioned, the VC707 does show link with some of the Xilinx images, though there could of course in theory be an issue with the interface.  I know this is not a whole lot of details - please let me know if there is something further I can test.
Best regards,
Hello Torben,
There are couple of other things to try:
- Ethernet cable, should be short and not through a router.
- VC707 hardware configuration, please see a picture attached.
- Running the application as administrator maybe.
- Wireshark, maybe you will be able to tell if at least packets are going out of your host computer.
- Firewall, we have seen problems when IT dpts having extra firewalls.
I hope that helps,

1 person likes this
Hi Arnaud,

I am aware that many things can obstruct the Ethernet interface (and have read your FAQ); but without link, there must be an error at a low (HW) level.

I tried to run the Xilinx RDF0165 application to test the interface; but that did not work either.  So perhaps something is wrong with my VC707 board.  Anyway, I will run a web-case with Xilinx to validate this.  I also have another board in back-order which should show up any time now. 

Once I have a board where the Ethernet is verified to work, I will get back if I still have problems with the BSP design.

Best regards,
Hi Arnaud,

I received another VC707 today - this seems to work with both your application and the Xilinx reference application.  So I guess Xilinx have sold me a defective board  :(  Sorry for bothering you - I expected Xilinx to have better QA given the board prices...

Best regards,
Hello Torben,
Thank you for the feedback.
We also had our lot of annoyances with VC707 but mostly around power supplies, several RMA iterations, etc..
Best Regards,
Login or Signup to post a comment