Start a new topic

problem with FMC104 firmware for ML605

[font=calibri]I am having trouble loading my FMC104 firmware onto a ML605 evaluation board from Xilinx. Previously, I was using an FMC150 with the same ML605 board, and everything was working well. I am using the same workflow to load firmware associated with each card, but I am getting different results.[/font]
[font=calibri]I have .bit files from 4DSP. I have tried loading these directly (the FMC104 still doesn’t work using the .bit file), but primarily I like to operate with a Flash memory bootup. So, I make .mcs files first from the .bit file. I use Xilinx’s ML605 Multiboot procedure and BPI PROM hardware parameters. Xilinx iMPACT indicates ‘Programed Successfully’ after the programming is complete.[/font]
[font=calibri]After programming, I use the FMC10xAPP.exe to test the board. The command prompt application fails with “Could obtain sipcid table <ffffffff>, exiting”. This seems to me that I’m not even able to communicate with the programmed ML605 board. When I use the FMC150app.exe and the FMC150.mcs/.bit firmware, everything works fine. I know that the FMC104 should be in the proper slot, but if it isn’t, I should at least get a different error like “could not detect FMC104 card”. It seems as though the firmware that I am loading onto the ML605 is not functional. Can you try to help me figure this out?[/font]


I just ran the reference design and it worked fine. In your case, It sounds like there is no communication. Which interface do you use, Ethernet or PCIe? I believe you are following the correct procedures, however, for the double check, could you check if
  1. the Ethernet LEDs on ML605 are blinking before and after programming bit file if the Ethernet interface is used?
  2. 112_ml605_fmc104 firmware is used for Ethernet interface and 173_ml605_fmc104_pci firmware is used for PCIe interface?

Do you have other Xilinx carrier boards or other FMc104? If yes, it would be good to try.

Hi Kyu,
I am using the ethernet port.
So, I tried programming the ML605 using the .bit configuration file again this afternoon. The the ethernet port had LED indicators before and after programming, and it was working briefly. I was able to talk to the device and get some readings after I mounted the FMC card.
Feeling ambitious, I next tried to program the flash memory so that the system is bootable. This broke the system. The ethernet port went dark, and now I cannot get it working again. I even reprogram the FPGA using the .bit file. Is there any reason why this might happen?
I will try to revert the system to the FMC150 program, and try again.
Yes, it happenned again.
The board works correctly after I revert to the FMC150 firmware. Then I can reprogram with a .bit file for the FMC104. The system breaks when I try to program the BPI flash with a FMC104 .mcs file. I made the .mcs file from the .bit file, because there was no .mcs file supplied with the FMC104 card. Perhaps when making the .mcs file, or when using it to program flash memory, one of my format/hardware settings was incorrect?
Do you have a .mcs file that works? Maybe you could describe the hardware settings that you use to make the file?



I'm sorry that we do not have any working mcs files. I think it's better to contact Xilinx.

Hi Kyu,
4DSP must have tested the FMC104 with the ML605 before releasing the hardware, firmware, and software combination, correct? Did 4DSP prepare .mcs files associated with this product development? As far as I can see, there aren't any relevant hardware changes from previous versions of the ML605, so the firmware that 4DSP developed should work. Are you able to successfully boot from the flash memory on a ML605 motherboard? Have you tried?
I doubt Xilinx will have very much expertise about a 3rd party product from 4DSP. Could you do a little more digging for me please?

We surely test .bit file and software before releasing and Kyu has even tested that again successfully. Converting a bit file into a mcs is not something we do, the bit file is working or not and if the bit file works, it works; if a bit file is working and a mcs is created then it should also work unless something is not right in the way you use impact (which is a Xilinx tool)

The question why a bit file cannot be converted to mcs is something you will need to check with Xilinx. The question to xilinx is not about 3rd product its about having a bit file (generated by Xilinx tools) not converting well to mcs using impact (a xilinx tool) for a reason or another and there surely, Xilinx will be more helpful than us.

Best Regards,

Login or Signup to post a comment