Start a new topic

Stellar IP Design

Hello,


I have changed my fmc150 stellar ip star removing the waveform memory from DAC. Now i want to conect the ouput from ADC to DAC, which is easy to do in Stellar Ip.
Now i'm having a problem because i want to send a "copy" from the data that is passing from ADC to DAC, to zedbhost_if. I want to use the existing router, so can i just connect the output from ADC to both DAC input and router input?

I have another problem with the FMC15xAPP that i have modified. I programmed the board with the go *.bit file and everything went okay, the autonegotiation was okay too, but when i run the APP it always say "Could not open device 1000"


I already tried your APP and your bit file and it shows the samething. What is causing this issue?

Thanks

I tried what you said, the problem wasn't solved.
Then i changed the ethernet cable and everything works fine. :S


Now, i ask some help because lmunoz said that the changes i have made to the vhdl code wasn't sufficient to do what i want to.


I thought that i only had to remove thw waveform memory and then change the FMC15xAPP. I would apreciate if you could give some hints about this situation.





Also, if everything is setup properly on the network side, you should be able to PING the card.  If firewall is off, ip addresses are set correctly and you can't ping it, then this suggest issue with the firmware build.


Okay i'll try tomorrow to see the firewall, because i did that IP adress configuration

Hi,

What is your computer IP address on the ethernet port that is connected directly to the Zedboard?


it must be set STATICALLY to 192.168.1.1 with gateway set to 192.168.1.10, subnet 255.255.255.0.


Basically the board is set to IP address 192.168.1.10 statically.  So to connect to it you have to directly connect your computer to the board and fix your computer's IP address.


Additionally you must make sure that firewalls are all OFF so that it won't block ports and connections.


Tony
I thought that after remove the wfm, i just have to take care with DAC and ADC frequencies when using the FMC15xAPP.


I already did everything as the doc say, with your files and the same problem occurs. I attached a photo to see.
"I just removed the waveform memory from the vhdl code and in Stellar IP i conected the output of ADC to the DAC input."

That won't work, because the two devices are sampling at different rates...

There might be an error in the figure for the jumpers, follow the description in the text not the picture. Make sure you are using the bit file provided by 4dsp not the one you built. Also post your console output.

I just removed the waveform memory from the vhdl code and in Stellar IP i conected the output of ADC to the DAC input.


I have tried to run the APP many times, and today it worked only one time.... I have already run it several times in other days and it worked, but now i'm having that error. I followed the doc explaining it. I used the jumpers in my zedboard like in the figure, but when i do it it says "done bit can't go high". If i used the jumpers in programming mode i'm capable of program the board, but then when i run the APP it says "Could not open device 1000"
Hi,


How did you connect the ADC to the DAC? I don't think that is easy to do, they have different rates and resolutions, did you match those and get it working? You should focus on that first once that is working sending to host is easy because it is already done. You send a trigger that starts capturing to a FIFO that gets read to the host. Streaming the ADC data to DAC requires matching the rates and resolution., if you just want to capture and repeat that is easier, just wire the adc data to that waveform repeat entity and pay attention to clock domains for commands and data.

So you haven't been able to run the reference application and bit file as provided?


Regards,
Luis
Login or Signup to post a comment