Start a new topic

Noise with FMC151


I am trying the reference design provided with ML605 and FMC 151. I am generating a 5MHz sine wave with an amplitude of 1V. I am communicating with the board with Ethernet.  I am using the following cable to connect the FMC 151 (MMCX) with a signal generator :

The waveform obtained with noise is attached with this post. I was wondering if the board would have so much noise in the waveform. I also noticed that the board is becoming much warmer IC. Is this normal?


Hello Paul,

Could you provide me with the serial number of your FMC151 and could you let me know what kind of firmware and software you are using in your setup? Are you using the bitsteam from 4DSP and the GUI from 4DSP?

Thanks in advance,

Thanks for the reply. The part no of the kit is FMC151-2-1-1-1 and serial no given was 0018 with PBC #KDJV000018. Firmware downloaded was for the reference design (418_ml605_fmc151). I used FMC analyzer to generate and observe data. I noted that DAC is working perfectly fine as it creates a sine wave without any noise. For ADC, when the frequency is changed, the wave appears to be a sine wave but has too much noise.

Help would be greatly appreciated.

Thanks & regards,

Are you using the loopback cable to connect the DAC0 to ADC0?  Or are you generating the signal externally?

Also, can you run the reference application (FMC15xApp) and look at/or attach the resulting *.txt file to the forum?

[font=verdana]I tweaked the reference design to generate analog values through DAC. I also modified the design to sample analog signal at 100 MHz and send these values to DAC. [/font]

[font=verdana]If a square wave is given as an input from a function generator, a square wave is observed at the [/font][font=verdana]output, but[/font][font=verdana] with [/font][font=verdana]a lot[/font][font=verdana] of noise again ([/font][font=verdana][i]picture name : square_wave2ADC(1).tif[/i][/font][font=verdana]). [/font]

[font=verdana]I went back to reference design provided by 4DSP and downloaded the firmware (available at[/font][font=verdana].[b][i].[/i][/b][b][i].[/i][/b][/font][font=verdana][i]/4Dsp/Common/Firmware/Recovery/418_ml605_fmc151[/i][/font][font=verdana] directory) for ML605 board. The connection was made from DAC0 to ADC0. [/font][font=verdana]Signal[/font][font=verdana] is generated from the DAC using the FMC analyzer software. A sine wave was generated without any problem and was observed [/font][font=verdana]on[/font][font=verdana] the oscilloscope (picture name[/font][font=verdana] :[/font][font=verdana] qfile_01.tif). [/font][/size]
[size=1em][font=verdana]But when the values are observed in the host computer using [/font][font=verdana]the FMC analyzer tool[/font][font=verdana] the waveform that's observed looks totally absurd [b][i](picture name :[/i][/b][/font] test_adc.jpg and text file : test_adc_1.txt ). [font=verdana]This makes me wonder if the ADC is really working or not. How can I make sure that the ADC is working?[/font][/size]

[font=verdana][size=1em]Any help/suggestion would be very helpful. Thank you.[/size][/font]

[font=verdana][size=1em]Paul [/size][/font]

To verify if the board is working or not, can you please run our DEFAULT (given) firmware with NO modifications with the REFERENCE software (not analyzer, but the Fmc15xApp.exe or you can build it from the source)?

Hook up a loopback cable from tx to rx and let us see the results on the txt files for both tx and rx.


[size=12pt][font=arial]Thank you for the reply. [/font][/size]
[size=12pt][font=arial]By reference design without any modifications you mean the firmware available at the following directory right. [/font][/size]
[size=12pt][font=arial][b][i]...[/i][/b][/font][/size]/4Dsp/Common/Firmware/Recovery/418_ml605_fmc151 directory
[size=12pt][font=arial]I downloaded this firmware in my all the previous discussions. [/font][/size]
[size=12pt][font=arial]I am having trouble in running the Fmc15xApp.exe reference software. I use windows 7, and when I double click this exe file (in.[b][i].[/i][/b][b][i].[/i][/b][/font][/size][b][i]/4dsp/FMC Board Support Package/ Bins/Fmc15App.exe[/i][/b]), it opens and closes immediately.
[size=12pt][font=arial]When you refer to the .txt file, do you refer to the text file that can be generated by analyzer software? [/font][/size]
[size=12pt][font=arial]Thanks again. [/font][/size]


You'll need to open a command prompt and execute in the command line:

Fmc150App.exe 1 ML605 device_index 0

where device_index is where your ethernet port device is (similar to the Analyzer value).

You should get a bunch of txt files for the generated tx function (software value sent on DAC) and the corresponding result should show up as adc files.

On the firmware - yes, use the default bit stream.


Thanks a lot for the reply.

I ran the application which created 4 text files.

These files are attached with the document. Please observe these values and let me know how to proceed.

Thank you.


Hi paul,

It definitely looks like there is something wrong with the hw or firmware.  But just to double check, what version is your BSP?  (there should be a date on the 4FM GUI application for the version).

And just to verify, your cable is just a standard loopback cable (short, without any filters or anything in between, right?)   

I will ask one of our guys to start the process to return the board.



The 4DSP version installed on the host computer is 2.230.1 released on 9 May 2014. There is no filter connected to the loopback system.

Please note that I connected DAC0 to ADC 0. I used the 2 of the following cables to create a loop-back design.

Please let me know how to proceed further.


Hi Paul,

Just one more try - attached is an exe file with the later build of the BSP for the 15xAPP.  please attach the adc files again with this run.


I replaced the FMC15xApp.exe with the new exe file that you gave me. When I run, I get the following error :

[b][i]The program can't start because of missing MSVCR110D.dll is missing from your computer. Try reinstalling the program to fix this problem. [/i][/b]

I am downloading the latest available BSP from 4DSP and I will run the FMC 15xApp available in the latest version.

I would like to know if the firmware in the RECOVERY directory would change depending on the BSP updates?

Yes, the firmware can be changed if there were issues found and fixed/addressed.  You should enable extraction of firmware when you update the BSP and use the latest one. 

I ran the latest software (BSP release as of last Friday) on a board that is under testing in our lab and the ADC results looks good.  I think I gave you the one which was built under debug mode (sorry).  If you download the latest BSP it will have the right build.


I updated by BSP to latest version (one released on last friday), but problem still persists. I have uploaded the latest set of text file after running FMC15xApp.exe.