Start a new topic

Zedboard + TCP/IP, and generation of bitstream

Hi, I'm wondering what types of limitations I will encounter when developing using the FMC30RF with the Zedboard over TCP/IP?

For example, when I use the 4FM GUI Control Application, the Zedboard does not show up under Active Device. I saw a note that says devices which communicate via Ethernet are not supported by the application. Does this mean the control application cannot use any form of communication via Ethernet, including TCP/IP, to control the Zedboard?

Also, is it possible to regenerate the bitstream using the reference project in Vivado? When I try to do so, I get error messages stating that certain parts of the IP are locked. Is it possible to unlock the various IP components? Eventually I'd like to add certain pieces of Xilinx IP (such as a DDS for waveform generation) and tie them directly into the design without having to recreate the design on my own.

Edit: I had some questions regarding the syntax of the demo application, as the documentation is a little unclear, but I have resolved this issue.

Dear Sir,

Correct the 4FM Gui only controls PCI hardware. This is because it is useful to run memory tests on 4DSP hardware, read PCI registers, etc..

The Vivado project compiles fine, am I right to assume you are using a different Vivado version; Maybe opening a Xilinx Webcase to ask for this specific issue related to Vivado and how to resolve that.

Best Regards,

Thanks Arnaud. You were correct about using a different Vivado version. I did a fresh install of Vivado 2013.2 with SDK, opened the .xpr project, and the warnings about the IP being locked were gone. However, when I tried to run synthesis, it fails, and I get the following message:

*** Running vivado
    with args -log zedb_fmc30rf.rds -m64 -mode batch -messageDb vivado.pb -source zedb_fmc30rf.tcl

\4DSP\Zedboard-FMC30RF\Firmware\zedboard_fmc30rf\zedboard_fmc30rf.runs\synth_1 was unexpected at this time.

Any ideas?

Edit: It appears to be related to the fact that the 4DSP software installs into the Program Files (x86) director, and these ( )'s cause issues with the .bat file used to run Vivado. Some information is here: [font=Verdana][size=78%][url=][/url][/size][/font]

I wasn't able to get their solution to work, but a workaround for me was to simply copy over the firmware directory containing the .xpr project to a location without ( )'s in it (I created C:\Test\ and moved it there), and everything worked fine. Arnaud, if you have a better solution, I'd love to hear it, but I thought I'd share in case anyone else has this issue.
Dear Sir,

Yeah Xilinx tools never worked on a path with spaces. We know it we surely manually copy the folder somewhere else indeed, this has became as natural as breathing is :)

The steps to recompile the design will be added in the next release of the BSP and we will highlight these aspects.

Best Regards,
This topic is being closed because the issue is considered as resolved by 4DSP. Feel free to create a new topic for any further inquiries.