Start a new topic

I cannot install the 4dspnet driver. How can I do?

[font=微][/size][size=0pt]Today, when I install my [color=#000000]4dsp[/color] develop kit, I cannot install my [color=#000000]4dsp[/color]net driver. [/size][/font]
[font=微][/size][size=0pt]The phenomenon is that I cannot run my C++ program I wrote before. The error is "Could not obtain NDIS(Ethernet) device enumeration... \n Check if the [color=#000000]4dsp[/color]net driver installed or if the service started?\n You can discard this error if you do not have any Ethernet based product in use.\n". [/size][/font]
[font=微][/size][size=0pt]I tried to search the "[color=#000000]4dsp[/color]net.sys" in my hard disk, in the folder "windows\system32\driver". But I cannot find it. I tried to double-click the "protinstall.exe" file in my "[color=#000000]4dsp[/color] develop kit\driver" folder for many times, also with administrator permission, still fail.[/size][/font]
[font=微][/size][size=0pt]Can you tell me what case usually leads to this error, and how can I fix it? Or does the driver rely on any other applications or services the OS should provides?[/size][/font]
[font=微][/size][size=0pt]Thank you.[/size][/font]
[font=微][/size][size=0pt]PS: The firmware I use is fmc150 daughter card with the xilinx ml605 kit.[/size][/font]

Dear Sir,

Can you provide me with your FMC150 serial number?

Best Regards,

I am having this same error with a VC707 and an FMC110. Could you let me know how this was fixed?
Thank you,

Dear Sir,

I am not sure if the customer fixed that or not. My questions about the serial number remained without answers. I assume the customer fixed it as he never asked for help anymore.

Normally the installer installs the driver and you have to press Ok just before it does so, can you confirm you are seeing that during the installation? Maybe you are on a domain and there are specific policy preventing the software to communicate with the device driver? If so you might want to try that on a machine not joined on your domain.

Windows 7 requirement, the installer does not block that yet but Windows XP is not supported anymore, can you confirm you are using Windows 7?

Can you open a command prompt with Administrator privileges, ie right click on "Command Prompt" and choose "Run as administrator". Then cd to the application folder and try to run it.

You can also try to manually start the ETHAPI driver service, in the same command prompt with admin privileges, enter: net start 4dspnet and let me know what happens.

Best Regards,
Thank you for your answer. I followed your instructions and opened CMD as an administrator. Now here is what I get:

C:\Program Files\4dsp\FMC Board Support Package\Bins>Fmc110APP.exe 1 VC707 0 0
Number of devices found : 4
  0. \DEVICE\{6588D54B-F7C5-45F8-AE61-B478072385D8}
    - Intel(R) 82577LM Gigabit Network Connection - Teefer2 Miniport
  1. \DEVICE\{9D7C66F2-355A-4506-AD55-E03E6F9CA751}
    - Intel(R) Centrino(R) Advanced-N 6200 AGN - Teefer2 Miniport
  2. \DEVICE\{C514F8FD-1E4E-45D4-9A06-0C729F2D905C}
    - Juniper Network Connect Virtual Adapter - Teefer2 Miniport
  3. \DEVICE\{C4D1BF5F-5968-4BA5-AE97-F488EAD30CC7}
    - Check Point Virtual Network Adapter For SecureClient - Teefer2 Miniport
Start of program
Could not obtain sipcid table (error ffffffff), exiting

It is still not working, but at least is an step forward. Any ideas?
Thank you,

Never mind. Took of Windows firewall and antivirus and now it is working. Thank you for your help.
Login or Signup to post a comment